CommentCaMarche
Recherche
Posez votre question Signaler

Comment creer une condition sur Excel. [Résolu]

hakimcom 60Messages postés dimanche 16 mars 2008Date d'inscription 29 juillet 2011Dernière intervention - Dernière réponse le 29 juil. 2011 à 14:49
Bonjour, je cherche a créer une condition sur une tableur excel!!!
exp:
si a1 < 1.02 alors b1=20.00
si a2 >=1.02 et a2 <1.06 alors b2 = 19.00
si a3 >=1.06 et a3 <1.09 alors b3 = 18.00
si a4 >=1.09 et a4 <1.12 alors b4 = 17.00
.....
....
...
..
.
comment dois je m'y prendre ? merci d'avance
Lire la suite 
Réponse
+0
moins plus
Bonjour,

Pour la 1° condition :
en B1
=SI(A1<1,02;20;"?")

Pour la 2°
en B2
=SI(ET(A2>=1,02;A2>1,06);19;"?")

etc...

Mais surtout déterminer les valeur "sinon" qui sont ici représentées par "?"

A+

Ajouter un commentaire
Réponse
+0
moins plus
Re Bonjour,

En relisant, je pense que la question n'est pas correctement posée. Il s'agit probablement de transformer une valeur en A en une valeur en B en imbriquant les conditions. Comme elles sont sans doute nombreuses mieux vaut faire un tableau de correspondance comme celà :
 A        B       
0      20       
1,02   19       
1,06   18       
1,09   17       
1,12   16       
...        ...       


puis en supposant que la valeur est saisie en D2 par exemple utiliser la formule suivante :

=RECHERCHEV(D2;A1:B21;2;VRAI)

A+

Ajouter un commentaire
Réponse
+0
moins plus
merci ta réponse ma aider, mais voila ce que j'ai fais:

B3=SI(ET(C3>=14,5);20)+(SI(ET(C3<14,5;C3>=14);19))+(SI(ET(C3<14;C3>=13,5);18))+(SI(ET(C3<13,5;C3>=13);17))+(SI(ET(C3<13;C3>=12,5);..........;(SI(ET(C3<5;C3>=4,5);1))+(SI(ET(C3>=4,5);0))

explication:
B3 reçois un teste logique, s'il est vrais la valeur qui correspond a la note va être renvoyer sinon c'est logiquement un zéro, et vu que j'ai plusieurs conditions, j'ai tout simplement additionné les valeur en retour c.a.d (0+0+valeur de la condition vrais +0+0+.....+0) selon la l'entré en C3. (c'est un barème d'un concourt de sport lancer de pois, temps du 400m .....ect chaque épreuve a son propre barème)

puis j'ai généralisé pour les autre cases de la même colonne.

merci pilas31 pour ton aide ;)
Ajouter un commentaire
Ce document intitulé «  comment creer une condition sur Excel.  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.