Posez votre question Signaler

Je ne peux plus lancer mes applications .exe [Résolu/Fermé]

ichtus 4Messages postés lundi 31 octobre 2005Date d'inscription 31 octobre 2005Dernière intervention - Dernière réponse le 25 avril 2011 à 16:57
Bonjour,
je suis sur windows xp version familiale
je viens de passer un coup de "spyboot search and destroy"
j'étais très content de détruire ce qu'il me proposait, jusqu'au moment où j'ai voulu lancer des applications
et tout ce qui finit par .exe ne fonctionne plus !!!!!
quelqu'un peut il m'aider ?

Le message d'erreur qu'il me donne est le suivant : "aucun programme n'est associé à ce fichier pour exécuter cette action. Créer une association en utilisatn l'application Options des dossiers dans le panneau de configuration". J'ai essayé d'associer .exe avec applications mais rien à faire

je suis désespéré !

Merci de votre aide
Lire la suite 
Réponse
+68
moins plus
J'ai eu la flemme de lire, mais j'avais ce problème, et j'ai trouvé ça par moi même :

Ouvrir Panneau de Configuration > Option des dossiers > Type de fichiers > Nouveau :

Comme extension vous mettez exe
Puis faites 'Avancé', dans la petite liste déroulante qui s'affiche, choisissez "Application".

Validez. J'espère que ça a résolu votre problème.

Les fichiers exécutables ne s'ouvrent plus

Nad- 8 août 2010 à 16:03
Je te remercie beaucoup Soda. Ca fait plus de deux semaines que je galère, que je scrute tous les forums et que je ne trouve aucune solution, que je fais part de mon souci à tout le monde et que personne ne comprend. Merci vraiment !
Sandra- 24 nov. 2010 à 18:22
Merci beaucoup, tu me sauves la vie là!!!
mél- 9 avril 2011 à 03:15
tu es un génie toi!!! ca fais 1 mois que ça me frustre et puis je pensais reformater mon ordinateur quand tout a coup je tombe sur ton message yaaaaaaaaaaaa!!!!!!! merci trop bien ça fonctionne!!!!!!!
Fredfromftown- 13 avril 2011 à 05:02
Merci ! Merci ! Merci !
tigrela- 15 avril 2011 à 09:37
Excellent merci,
juste une précision : il faut être rapide et lancer la manip dès que l'écran s'ouvre et que le menu démarrer est actif car si on attend l'affiche complet du bureau cela ne marche plus
tigrela
Annonces
 
moins plus
Réponse
+27
moins plus
double post car j'ai trouver la solution sur un autre forum !

Dans un Editeur de texte quelconque faire un copier-coller du texte ci-dessous, enregistrez-le du nom que vous voulez mais en ayant soin de lui affecter une extension .inf. Il ne vous restera plus qu' à faire un clic droit dessus et de choisir " Installer ". Et une fois la base de registre rétablie de télécharger au plus vite le premier patch disponible sur Internet.
[Version]
Signature="$Chicago$"
[DefaultInstall.NT]
AddReg=Fix
RenFiles=Ren_rundll
[DefaultInstall]
AddReg=Fix
RenFiles=Ren_rundll
[Fix]
HKCR,exefile\shell\open\command,,0,"""%1"" %*"
[Ren_rundll]
rundll32.exe,run32.exe

scortine- 12 avril 2011 à 09:23
Un énooooOooorme merci!!!
Gigi- 13 avril 2011 à 15:23
Solution excellente, ca fonctionne
hopper- 18 avril 2011 à 20:15
Milles merci !
Neofit- 23 avril 2011 à 17:30
Toujours en ce moi d'avril, tout simplement : une reconnaissance envers un Professionnel du Net".
Cela répare immédiatement. tous mes mal-fonctionnements, des .exe qui ne se lançaient pas, le "configurateur de programme par défaut "qui partait en erreur, le Regedit qui ne se lançait que via des astuces, etc...

Ouf et Merci.

Cerise sur le gâteau, on peut avoir quelques explications de la solution. Car je suis un peu comme un enfant qui fait sans comprendre. Qui peut m'aider à grandir?
screwu- 25 avril 2011 à 16:57
Thanxxx!!
Annonces
 
moins plus
Réponse
+16
moins plus
Hello!
Me revoilà, j'ai entretemps trouvé une solution.
Voici la marche à suivre pour résoudre le problème :
1. Ouvrir un notepad (démarrer > executer > notepad). (Le notepad se lancera malgré le fait que les .exe ne sont pas reconnus, me demandez pas pourquoi.)
2. Collez dans le notepad le code ci-dessous (code qui commence par "Windows Registry" et finissant par "@="\"%1\" %*"")
3. Enregistrez le fichier avec l'extention .reg
4. Double clickez sur ce fichier et acceptez d'ajouter les valeurs au registre. Voilà, c'est tout!
(Pardonnez mon double-post, mais j'étais très très embêté quand après avoir éradiqué le virus du PC de mon client, plus rien ne fonctionnait! Heureusement, c'est résolu et il n'est toujours pas revenu (le client, pas le virus))
En espérant que ça servira à quelqu'un!

Code en question :

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\.exe]
@="exefile"
"Content Type"="application/x-msdownload"

[HKEY_CLASSES_ROOT\.exe\PersistentHandler]
@="{098f2470-bae0-11cd-b579-08002b30bfeb}"

[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"TileInfo"="prop:FileDescription;Company;FileVersion"
"InfoTip"="prop:FileDescription;Company;FileVersion;Create;Size"

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

[HKEY_CLASSES_ROOT\exefile\shell]

[HKEY_CLASSES_ROOT\exefile\shell\open]
"EditFlags"=hex:00,00,00,00

[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shell\runas]

[HKEY_CLASSES_ROOT\exefile\shell\runas\command]
@="\"%1\" %*"

krob56- 28 avril 2008 à 03:11
Merci beaucoup.
Moi aussi, 3 ans après , j'ai pu faire refonctionner l'ordinateur de ma fille grâce à ce fichier.
C de Tahiti
Nanou- 31 juil. 2008 à 18:41
pareil que les deux au dessus de moi, un grand merci venant du futur :p
Shqmo- 22 nov. 2008 à 05:17
Salut a toi V !! j suis vraiment en train de déprimé ^^ je ne peux plus lancer mes applications .exe !! j'ai tester ce que tu explique sur le forum mais je ni y arrive pas :p j'aimerais que tu me passe ton adresse e-mail et que tu m'aide en ligne, si ca te pose pa de probleme ! merci de me répondre a biento j'espere...
noufette- 4 juil. 2009 à 11:37
bonjour suite au meme probleme
j'ai essayer de faire votre manipulation lu sur internet
mais je n'y arrive pas pouvais vous me donner plus de renseignement merci
yannpl7- 14 févr. 2010 à 10:39
Grand Merci
Réponse
+9
moins plus
Je galère depuis 1 semaine, je viens de trouver la solution par hasard :
1. Cliquer sur le bouton "Démarrer"
2. Cliquer sur "Panneau de configuration"
3. Double-cliquer sur "Options des Dossiers"
4. Dans l'onglet "Types de fichiers", cliquer sur le bouton "Nouveau"
5. Dans la boîte de dialogue, cliquer sur le buton "Avancé" puis remplir les champs "Extension" avec "EXE" et "Type de fichier associé" avec "Application" puis valider en cliquant sur le bouton "Ok".
6. Vous devez désormais lire "S'ouvre avec : %1" dans "Détails concernant l'extension 'EXE' ". Si ça n'est pas le cas, un nouveau bouton "Restaurer" doit normalement apparaitre : cliquez sur celui-ci.
7. Fermez la boîte de dialogue "Options des Dossiers" en cliquant sur le bouton "Fermer" puis essayez de lancer un logiciel...

Réponse
+4
moins plus
Bon je m'auto-edit, problème résolu à l'instant pour ma part grace à un autre topic de CCM qui m'a permis de lancer un traitement de texte (l'astuce étant de ne pas ouvrir directement l'exe mais un fichier texte). A partir de là, l'astuce de V fonctionne et ce immédiatement, sans besoin de redémarrer ! Merci à toi !

z- 30 mars 2010 à 20:10
Salut Merci pour cette astuce d'astuce ca a marché pour moi aussi mais j'ai du lire toute la liste de commentaire pour arriver jusque là... dommage qu'on en puisse pas faire noter de façon plus directe pour les commentaire qui aident d'un coup...
Réponse
+2
moins plus
il n'y a pas d'associations pour les .exe puisque ce sont eux même les programmes (fichier executables donc non dépendant,autonome), à la différence des fichiers qui s'ouvrent avec les programmes (cad .exe) fichier dépendant des programmes.

Réponse
+2
moins plus
Alors tout d'abord un grand merci à V qui m'a bien arrangé sur le coup !

Je vais peut-être pouvoir en débloquer certains ! Mais pas tous malheureusement

Comme beaucoup d'entre vous, moi aussi je ne pouvais pas ouvrir le .reg de V (ou si mais avec notepad -_-)
Par contre, à l'aide de la commande executer, je pouvais lancer le regedit. Et à partir de regedit, j'ai fait fichier puis importer... et là j'ai pris le fichier .reg de V !

et pouf, magie ^^

Réponse
+2
moins plus
merci à V, j'ai eu le même pb sous système de Vista, j'ai ouvert le wordpad, car notepad ne fonctionnait pas. ça a marché après avoir collé le code que t'as affiché. c'est génial.

Réponse
+1
moins plus
Essaie d'abord de désinstaller SPYBOOT. Je suppose qu'il a finit son travail. Après ça, si le problème est résolu, c'est tant mieux, on connait le coupable.Sinon, réinstalle le et essaie une restauration de ton système avec l'utilitaire "demarrer->tous les programmes->accessoires->outils systèmes".

Je serai étonné quand même que SPYBOOT soit coupable, mais il ne faut écarter aucune hypothèse.

Du courage!!

ichtus 4Messages postés lundi 31 octobre 2005Date d'inscription 31 octobre 2005Dernière intervention - 31 oct. 2005 à 15:48
Merci pour ton conseil
entre temps j'ai été surfé sur un autre forum où j'ai trouvé la solution, je pense qu'il y avait un virus non détecté par norton antivirus
j'ai téléchargé un patch qui m'a miraculeusement remis tous mes fichiers exe d'aplomb
Réponse
+1
moins plus
merci pour votre aide!

Réponse
+1
moins plus
Juste pour dire: MERCI V, ça fait 4 jours que je galérais, et là tout marche...merci pour la manip

Réponse
+1
moins plus
Merci le truc du registry a fonctionné à merveille.

Réponse
+0
moins plus
Bonjour,

Même problème rencontré suite à manipulations sur partitions (suppression Linux, modif taille partitions Windows, etc...). Plus aucun ".exe" ne pouvait être lancé.

Réglé instantanément, sans avoir à redémarrer le PC, avec le ".reg" de V.

Un grand merci à lui - et à tous les autres participants de tous les autres forums - pour le temps consacré à aider les autres.

Romain

Réponse
+0
moins plus
bonsoir,
Le problème a été résolu par le .reg de V. (merci a lui) que j'ai pu récupérer parce que firefox démarre malgré le virus...Chacun pourra en tirer la conclusion quant aux programme de navigation a utiliser.

Réponse
+0
moins plus
Milles merci a V moi aussi ça m'a résolu mon soucis qu'elqu'un a une idée de où ? Il me semble que c'est "la protection residentiel" de spybot qui a foutu le bordel chez moi...

Encore merci.

Réponse
+0
moins plus
Merci a V j'avais le meme probleme que tout les autre maintenant tout fonctionne :P !!

Réponse
+0
moins plus
super génial, le code posté par "V" a fonctionné chez moi. Merci infiniment, TeKa

Réponse
+0
moins plus
Merci V,
Cela fait au moins 3 ans que je ne pouvais pas regler ce problème !
Je vous remercie indefiniment..

Réponse
+0
moins plus
Je confirme :
J'ai testé la manip de V suite à un problème de lancement d'exe et tout marche nickel maintenant.

Descriptif du problème :
Les setup d'exe tels que adsltv par exemple ne se lancaient pas. Le programme tournait en tâche de fond mais était inactif.

Après avoir fait la manip de V, j'ai cliqué une fois sur le setup et il se lance correctement.

Je pense qu'après avoir été infecté par certains virus les programmes de nettoyage font sauter le root\exefile car il manquait dans mon registre.

MERCI V

Ce document intitulé «  je ne peux plus lancer mes applications .exe  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.