Chercher une valeur dans une plage de cellule [Fermé]

Fr68Ch - 5 août 2010 à 12:52 - Dernière réponse : animaniax 8 Messages postés mardi 9 juin 2009Date d'inscription 18 mars 2015 Dernière intervention
- 18 mars 2015 à 16:01
Bonjour,

J'aimerais utiliser une fonction qui permet de chercher une valeur dans une plage de cellule excel

Par exemple dans la plage B1:B10, je recherche la valeur (qui ne peut être qu'unique) ; si je trouve cette valeur, la valeur à reporter dans la cellule est 1

Voila

Merci d'avance
Afficher la suite 

6 réponses

Patrice33740 6704 Messages postés dimanche 13 juin 2010Date d'inscription 13 février 2018 Dernière intervention - Modifié par Patrice33740 le 10/08/2010 à 11:12
+9
Utile
En supposant que la valeur a chercher soit entrée en A1, que la plage où chercher soit de B1 à B10 dans la cellule où tu veux le résultat tapes :

=SI(ESTNA(EQUIV(A1;$B$1:$B$10;0));"";1)


Nicolas dit toujours : « C'est facile quand on connait la réponse ! »
Cette réponse vous a-t-elle aidé ?  
lermite222 8728 Messages postés dimanche 8 avril 2007Date d'inscriptionContributeurStatut 27 janvier 2014 Dernière intervention - 5 août 2010 à 13:33
+2
Utile
2
Bonjour,
C'est ça que tu cherche ?
Sub ChechVal()
Dim Cel As Range
Dim Plage As Range
Dim CH As Variant
    CH = InputBox("Entrez la valeur à chercher")
    If CH = "" Then Exit Sub
    Set Plage = Range("B1:B10")
    For Each Cel In Plage
        If Cel = CH Then
            Range("A1") = Cel
            Exit Sub
        End If
    Next Cel
End Sub

A+
Bonjour
Merci de cette prompte réponse
J'ai testé et cela ne fonctionne pas
Pour tester, j'ai entré une valeur croissante de 1 à 10 dans le range B1 à B10
j'ai lancé le débogage pas à pas et bien que la valeur entrée dans l'inputbox existe, il n'entre jamais dans Range A1=Cel
je pense qu'il y a un problème de type de variable car CEL est de type Range et CH est de type Variant
Si tu as une idée...
Merci d'avance
lermite222 8728 Messages postés dimanche 8 avril 2007Date d'inscriptionContributeurStatut 27 janvier 2014 Dernière intervention - 10 août 2010 à 11:59
Non, vu que CH est en variant l'inputBox renvoi un string.
Remplace la déclaration de CH
Dim CH As Double

A+
animaniax 8 Messages postés mardi 9 juin 2009Date d'inscription 18 mars 2015 Dernière intervention - 18 mars 2015 à 16:01
+2
Utile
=NB.SI(B1:B10;valeur)

ça vous renverrait le nombre de valeurs contenues dans votre plage. ici, 1
f894009 12686 Messages postés dimanche 25 novembre 2007Date d'inscription 14 février 2018 Dernière intervention - 10 août 2010 à 11:20
0
Utile
Bonjour,

Sub recherche()
Dim Val_recherche, C, Addr

Val_recherche = InputBox("Entrez la valeur à chercher")
If Val_recherche = "" Then Exit Sub

With Worksheets("Feuil1").Range("b1:b10")
Set C = .Find(Val_recherche, LookIn:=xlValues)
If Not C Is Nothing Then
Addr = C.Address
Range("A1") = Range(C.Address).Value
Else
'Code si pas trouvee

End If
End With

End Sub

Essayez si cela vous convient

Bonne continuation