Problème de javaScript [Fermé]

pirate - 26 juil. 2010 à 09:55 - Dernière réponse :  pirate
- 26 juil. 2010 à 12:15
Bonjour,
J'ai fait un menu déroulant au passage de la souris. Le problème c'est que je ve maintenant qu'il se déroule uniquement que lorsque je clic dessu.
voici mon css
#monmenu {font-family: trebuchet ms, arial, tahoma, verdana, sans-serif; font-size: 90%; font-weight:bold;}
#monmenu ul ul {display: none; left: 144px; top: -1px; position: absolute; margin:0px; padding: 0px; border: 1px solid #B0B0B0;}
#monmenu li{list-style-type: none; position: relative; width: 140px; height: 30px; background-color: #EEF3F7; padding: 2px; margin: 0px}
#monmenu li li{list-style-type: none; position: absolute; top: -40%; width: 780px; height: 400px; background-color: white; padding: 2px; margin: 0px}
#monmenu li:hover, #monmenu li.sfhover {background-color: white;}
#monmenu li:hover.active {url: ("Accueil.php"); background-color: white;}
#monmenu li a {text-decoration:none;}
#monmenu li:hover ul.niveau2, #monmenu li li.onclick ul.niveau3 {display: block;}
#monmenu li.plus {background-position:right; background-image: url(illustrations/ fdroite.gif); background-repeat: no-repeat; border-bottom: 1px solid #B0B0B0;}

J'ai essayé de remplacer hover par onclick mais ca marche pas non plus
existe t-il une solution?
merci d'avance
Afficher la suite 

5 réponses

Breub62 3158 Messages postés lundi 7 juin 2010Date d'inscription 17 avril 2014 Dernière intervention - 26 juil. 2010 à 09:57
0
Utile
1
Ceci est la partie css. Fais voir le code propre de ton menu stp.
<ul class="niveau1">
<li class="active" style="positon: absolute; top: -50%;"> Qui somme nous?
<ul class="niveau2" style="width: 600px; height: 400px; border: 0px;">
<p><h5><a href="Presentation.html"> Présentation de l'entreprise :</a></h5></p>
</ul>
</li>
<li> Entreprise
<ul class="niveau2" style="width: 1900px; height: 400px; border: 0px;">
<a href="entreprise.php"><img src="images/entreprise1.png" style=" left: 173px; width: 140px; heigh: 50px;" class="imageflottante" alt="Image flottante"/></a><br/><br/>
</ul>
</li>
<li> Client
<ul class="niveau2" style="width: 600px; top: -50%; height: 400px; border: 0px;">
<a href="client.php"><img src="images/client.png" style=" left: 173px; width: 140px; heigh: 50px;" class="imageflottante" alt="Image flottante"/></a>
</ul>
</li>
</ul>


voici mon menu
0
Utile
2
On m'a dit que c'était un problème de javascript mais voila je c pas comment faire pour le résoudre
Breub62 3158 Messages postés lundi 7 juin 2010Date d'inscription 17 avril 2014 Dernière intervention - 26 juil. 2010 à 10:42
Je te conseille de suivre cette discussion qui semble correspondre exactement à ton problème.
effectivement g vue cette discussion mais la solution posposée ne répond pas mon problème