Menu

EXCEL Si 3 conditions, 3 résultats différents [Résolu/Fermé]

rnalextexmex 66 Messages postés jeudi 6 mai 2010Date d'inscription 9 mai 2017 Dernière intervention - 11 mai 2010 à 15:03 - Dernière réponse :  ghofran
- 26 févr. 2015 à 17:11
Bonjour,

Je suis confronté à un problème sur excel.
J'aimerai trouver le moyen de remplir une cellule avec 3 possibilités de réponse ( "OUI" "NON" ou "N.A." ) , en fonction du texte que je vais écrire dans une autre cellule.

Dans mon cas je veux:
OUI si la cellule ne contient pas de texte (par défaut)
NON si elle contient le lettre N
N.A. si elle contient la lettre B


Dit comme ça cela parait bidon, mais je suis depuis une après midi la dessus!
Aidez moi SVP! =)

Merci d'avance!


Afficher la suite 

9 réponses

rnalextexmex 66 Messages postés jeudi 6 mai 2010Date d'inscription 9 mai 2017 Dernière intervention - 11 mai 2010 à 15:14
+16
Utile
Merci Neliel et chossette9 , grâce à vous j'ai réussi! c'était bien ça.

c'est fou comme les problèmes se résolvent vite grâce à ce forum! Merci à tous.

.... je vais quand même essayer de comprendre la formule, histoire de ne plus être confronté à ce problème par la suite.

thx!
Cette réponse vous a-t-elle aidé ?  
Neliel 6217 Messages postés jeudi 9 juillet 2009Date d'inscriptionContributeurStatut 20 mars 2017 Dernière intervention - 11 mai 2010 à 15:07
+13
Utile
Bonjour,

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))
chossette9 4429 Messages postés lundi 20 avril 2009Date d'inscriptionContributeurStatut 12 septembre 2014 Dernière intervention - 11 mai 2010 à 15:08
+6
Utile
Bonjour,

en supposant que la cellule à tester est A1, on écrit en B1 :
=SI(A1="N";"Non";SI(A1="B";"N.A";SI(ESTVIDE(A1);"Oui";"")))

Cordialement.
Neliel 6217 Messages postés jeudi 9 juillet 2009Date d'inscriptionContributeurStatut 20 mars 2017 Dernière intervention - 11 mai 2010 à 15:16
+4
Utile
5
Je vais t'aider à la comprendre, il s'agit en fait de 2 SI imbriqué (pour mon cas)

En français, cela donne:

=SI(A1="N";"NON";SI(A1="B";"NA";"OUI"))

SI la cellule A1 contient "N" alors écrire "NON" SINON SI la cellule A1 contient "B" alors écrire "NA" SINON écrire "OUI"
chossette9 4429 Messages postés lundi 20 avril 2009Date d'inscriptionContributeurStatut 12 septembre 2014 Dernière intervention - 11 mai 2010 à 15:19
Oui mais dans ce cas là, tu ne prends pas en compte la demande OUI si la cellule ne contient pas de texte (par défaut) , c'est pourquoi j'ai imbriqué 3 SI :

SI A1 contient "N" alors écrire "Non", SINON si A1 contient "B" écrire "N.A", SINON si A1 est vide écrire "Oui", sinon ne rien écrire.

Cordialement.
Neliel 6217 Messages postés jeudi 9 juillet 2009Date d'inscriptionContributeurStatut 20 mars 2017 Dernière intervention - 11 mai 2010 à 15:22
Tu as parfaitement raison... mais tu as fait du zèle! Il n'y avait que 3 possibilités selon son énoncé! ;-)
chossette9 4429 Messages postés lundi 20 avril 2009Date d'inscriptionContributeurStatut 12 septembre 2014 Dernière intervention - 11 mai 2010 à 15:25
Ces 3 possibilités en appelle une quatrième par défaut : Si c'est différent des 3 conditions, alors on ne met rien.

De toutes façons, les deux solutions fonctionnent.
Merci Beaucoup ça maaaaaaarcheeeeeeeee