Signaler

Excel compter cellules [Résolu]

Posez votre question jmbibi 1Messages postés jeudi 18 août 2005Date d'inscription 18 août 2005 Dernière intervention - Dernière réponse le 17 sept. 2015 à 11:03
AU SECOURS !!
DANS UNE FEUILLE EXCEL COMMENT COMPTER LE NOMBRE DE CELLULE CONTENANT UN MOT (JE DIS BIEN CONTENANT, ENTRE AUTRE, UN MOT) LES CELLULES CONTENANT CE MOT SEUL OU CE MOT AVEC D'AUTRES OU UNE REFERENCE.
MERCI J'AI UN GROS PRBLÈME CAR PLUS DE 60 000 CELLULES.
Afficher la suite 
Utile
+89
moins plus
Salut,

Pour compter un mot, la fonction "NB SI" devrait faire l'affaire.
Aide excel :
Supposons que la plage A3:A6 contienne, respectivement, « pommes », « oranges », « pêches », « pommes » :
NB.SI(A3:A6;"pommes") égale 2

Pour compter le nombre de cellules contenant un mot avec d'autres,
il faut utiliser le symbole générique "*".
Supposons que la plage A3:A6 contienne, respectivement, « pommes », « oranges », « pêches », « pommes », « Pêches abricot »
NB SI(A3:A6;"*pêches*") égale 2

Pour une référence, je ne sais pas.
Night angel- 2 janv. 2015 à 14:00
Merci aussi
Répondre
Anubys- 1 févr. 2015 à 22:43
Super parfait !
Répondre
fanto- 12 févr. 2015 à 22:35
waw 9 ans!!! c fou!
Répondre
Reboot- 17 sept. 2015 à 11:03
Pour une référence, il faudra seulement ajouter un &, qui marque le changement de format

Exemple : si on veut compter le nombre de fois ou mes cellules contiennent le mot "pêches" + une valeur en D2 sur une plage A1:C50

=NB.SI(A1:C50;"*pêches*"&D2)
Répondre
Ajouter un commentaire
Utile
+26
moins plus
Question un poil + technique mais du même genre: pour compter le nombre de cellules NE CONTENANT PAS LE CHIFFRE ZERO, et dispersées sur plusieurs colonnes (pas sur une seule même plage de données A1:A7).
Ajouter un commentaire
Utile
+16
moins plus
une petite macro devrait faire ton affaire.
Isma- 23 sept. 2010 à 18:14
Est ce qu'il est possible d'appliquer ceci lorsque l'on veut faire une somme dans plusieurs feuilles Xls
Répondre
Ajouter un commentaire
Utile
+7
moins plus
Excellent!!
Merci pour cette super aide !!
Titeuf- 13 févr. 2011 à 18:17
Excellent!!
Merci beaucoup.
Répondre
nina- 16 mars 2015 à 08:45
vraiment merci !!! EXCELLENT !!
Répondre
Ajouter un commentaire

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !