Posez votre question Signaler

Dévérouiller un dossier

gderac - Dernière réponse le 27 sept. 2007 à 07:12
Bonjour à tous

Je cherche à acceder à ma partition système depuis linux mandrake 10.1. Je passe par "Espace disque libre", clique droit sur ma partition /dev/hda2 dont le point de montage est /mnt/win_d là je clique sur "Ouvrir le gestionnaire de fichier" et j'obtiens le message suivant:

Impossible d'entrer dans file:/mnt/win_d. Vous n'avez pas le droit d'accéder à ce dossier.

Effectivement, qd je me rend dans le repertoire /mnt, le dossier win_d est vérouillé (présence d'un cadena dessus).

Question: Comment dévérouiller ce dossier?...

Merci de vos réponses ;-)

A +
Lire la suite 
Réponse
+0
moins plus
Salut,

il te faut les droits de lecture/écriture sur le dossier en question.

Pour vérifer, ouvre une console et tapes :
$ ls -l /mnt | grep win_d


Pour modifier les droits en root :
$ cd /mnt
$ su
password:
# chmod 646 win_d
# exit


Pour comprendre les commandes utilisées :
http://www.linux-france.org/article/debutant/debutant-linux.html

Découvrir sa Mandriva : http://www.ccr.jussieu.fr/urfist/mandrakours/mandrakours.htm

Et je suis sur que tu as lu la doc officiel de Mandriva ;)
http://www1.mandrivalinux.com/fr/fdoc.php3

voili voilou ^_^
Ajouter un commentaire
Réponse
+0
moins plus
ok merci mais la commande chmod 646 win_d donne:

[root@localhost mnt]# chmod 646 win_d
chmod: modification des permissions de `win_d': Read-only file system

Ce qui selon moi est du au fait que le dossier soit vérouillé donc la commande chmod n'agit pas....

voilà, si tu as des idées, je t'écoute :-)
Ajouter un commentaire
Réponse
+0
moins plus
Read-only file system
Ta partition est surement du ntfs surlequel Linux ne peut pas ecrire lais uniquement lire.
Ajouter un commentaire
Réponse
+0
moins plus
oui effectivement, c du ntsf, et je cherche uniquement à lire, ce que je n'arrive pas à faire malgré que ds les permissions du dossier win_d, il y ait un droit en lecture pour le propriétaire...
Ajouter un commentaire
Réponse
+0
moins plus
Humm le NTFS !

recommence avec :
chmod 444 win_d

pour avoir les droits de lecture.

en tout cas pour avoir les droits d'écriture en NTFS, ce n'est pas possible, il faut que ta partition soit en FAT32.
Ajouter un commentaire
Réponse
+0
moins plus
Salut,
il faut alors changer les droits pour le groupe et les autres afin de permettre la lecture.
chmod 446 win_d en root

Sinon tu peux modifier ton fstab pour ne pas avoir à refaire la meme manip.
Ajouter un commentaire
Réponse
+0
moins plus
je viens de tester ce que vous m'avez dit et voilà le résultat:

[gderac@localhost gderac]$ su
Password:
[root@localhost gderac]# cd /mnt
[root@localhost mnt]# chmod 446 win_d
chmod: modification des permissions de `win_d': Read-only file system
[root@localhost mnt]# chmod 444 win_d
chmod: modification des permissions de `win_d': Read-only file system
[root@localhost mnt]#

évidemment, partition non lisible après un tel message...

pfffff, ça commence à être lourd tout ça lol

Encore des idées? :-)
Ajouter un commentaire
Réponse
+0
moins plus
Montre ton fstab depuis "/etc"
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

Les permissions sur les droits d'accès aux partitions se gèrent dans le "/etc/fstab", et non pas avec un simple "chmod".
Jette un oeil à ce sujet dans la FAQ de CCM :
http://www.commentcamarche.net/faq/sujet-96
Ajouter un commentaire
Réponse
+0
moins plus
Salut

J'ai suivi la procédure indiquée sur ton site, jipicy, et voici ce que j'obtiens sur ma partition windows système après avoir ouvert l'éditeur vi sur le fichier fstab:

/dev/hda2 /mnt/win_d ntfs umask=0,iocharset=iso8859-15,nls=iso8859-15,codepage=850,ro 0 0

Je ne sais pas à quelle niveau ds cette ligne il faut que je rajoute
user,gderac,gid=1001,umask=027,ro car il s'agit bien de rajouter ça, n'est-ce pas? (au préalable j'ai crée le groupe windows et j'y ai rattaché l'utilisateur gderac comme indiqué plus haut ds la page)

saga9, voici à quoi ressemble l'intégralité de mon fstab:

/dev/hda5 / ext3 defaults 1 1
/dev/hda7 /home ext3 defaults 1 2
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hda2 /mnt/win_d ntfs umask=0,iocharset=iso8859-15,nls=iso8859-15,codepage=850,ro 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,sync,codepage=850,noauto,ro,exec,users 0 0

Voilà merci encore et je crois que je tiens le bon bout :-)

A +
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

Commentes la ligne concernant ton "/dev/hda2" en rajoutant un dièse (#) devant comme suit :
# /dev/hda2 /mnt/win_d ntfs umask=0,iocharset=iso8859-15,nls=iso8859-15,codepage=850,ro 0 0

et rajoute cette ligne en dessous :

/dev/hda2 /mnt/win_d ntfs user,noauto,gid=1001,umask=027,ro 0 0

Relances la lecture du "fstab" en tapant en "root" :
mount -a
Si ce n'est pas suffisant rebootes ta machine
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

voilà, j'ai rajouté cette ligne:

/dev/hda2 /mnt/win_d ntfs user,noauto,gid=1001,umask=027,ro 0 0

dans fstab dont le contenu est donc celui ci:

/dev/hda5 / ext3 defaults 1 1
/dev/hda7 /home ext3 defaults 1 2
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0
/dev/hda2 /mnt/win_d ntfs umask=0,iocharset=iso8859-15,nls=iso8859-15,codepage=850,ro 0 0
/dev/hda2 /mnt/win_d ntfs user,noauto,gid=1001,umask=027,ro 0 0
none /proc proc defaults 0 0
/dev/hda6 swap swap defaults 0 0
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,sync,codepage=850,noauto,ro,exec,users 0 0

Après j'ai fait un mount -a mais rien ne changait alors j'ai rebooté mais tjs pareil....

Je suis allé les permissions ds le dossier win_d du rep /mnt et sous "Appartenance" je peux lire que

pour Utilisateur: root et
pour Goupe: root

J'ai sur mon bureau une icône disque dur (qui représente mon hda2 ) mais qd je l'ouvre, il me dit "impossible de rentrer ds le dossier /mnt/win_d"

une idée?...

Merci et a +
Ajouter un commentaire
Réponse
+0
moins plus
Re-

Je t'avais dit de "commenter" l'ancienne ligne concernant "/dev/hda2", mais apparemment tu ne l'as pas fait !!!
faut que ton fichier "/etc/fstab" ressemble à ça :
/dev/hda5 / ext3 defaults 1 1

/dev/hda7 /home ext3 defaults 1 2

none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-15,sync,codepage=850 0 0

/dev/hda1 /mnt/win_c ntfs umask=0,nls=iso8859-15,ro 0 0

# /dev/hda2 /mnt/win_d ntfs umask=0,iocharset=iso8859-15,nls=iso8859-15,codepage=850,ro 0 0

/dev/hda2 /mnt/win_d ntfs user,noauto,gid=1001,umask=027,ro 0 0

none /proc proc defaults 0 0

/dev/hda6 swap swap defaults 0 0

/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-15,sync,codepage=850,noauto,ro,exec,users 0 0

Corrige et relance "mount -a" (au pire reboote)
Ajouter un commentaire
Réponse
+0
moins plus
OK merci bcp, ça marche maintenant :-)

A +
Ajouter un commentaire
Réponse
+0
moins plus
hello
j'ai un problème avec mes disques ntfs: la partition sda1 du dd principal (sur laquelle trone enore xp) et sdb1 d'un disque externe
Pour sda1, je n'avais pas encore essayé, mais désormais je n'ai plus acces a sdb1. Je suis retourné un instant sur xp et lorsque je suis revenu sur linux, sdb1 n'était plus accessible (que j'avais rendu accessible grace a ntfs-3g et ntfs-config (pour ceux qui connaissent la manip..)
j'ai suivi les conseils de ce fil, mais rien n'y fait

dans mon fstab:

#UUID=2810EB9810EB6AF0 /media/sda1 ntfs-3g defaults,locale=fr_FR.UTF-8 0 1
UUID=2810EB9810EB6AF0 /media/sda1 ntfs defaults,locale=fr_FR.UTF-8 0 1

/dev/sdb1 /media/stockage ntfs-3g defaults,locale=fr_FR.utf8 0 0
#/dev/sdb1 /media/stockage ntfs user,noauto,gid=1001,umask=027,ro 0 0

suivant le #, j'ai (en tapant mount -a)

$LogFile indicates unclean shutdown (0, 0)
Failed to mount '/dev/disk/by-uuid/2810EB9810EB6AF0': Opération non supportée
Mount is denied because NTFS logfile is unclean. Choose one action:
Boot Windows and shutdown it cleanly, or if you have a removable
device then click the 'Safely Remove Hardware' icon in the Windows
taskbar notification area before disconnecting it.
Or
Run ntfsfix version 1.13.1 on Linux unless you have Vista.
Or
Mount the NTFS volume with the 'ro' option in read-only mode.

OU:

mount: type erroné de système de fichiers, option erronée, super bloc erroné sur /dev/disk/by-uuid/2810EB9810EB6AF0,
codepage manquante ou autre erreur
Dans quelques cas certaines informations sont utiles dans syslog - essayez
dmesg | tail ou quelque chose du genre

une idée?
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

Mount is denied because NTFS logfile is unclean. Choose one action:
Boot Windows and shutdown it cleanly, or if you have a removable
device then click the 'Safely Remove Hardware' icon in the Windows
taskbar notification area before disconnecting it


Essaie de faire ce qu'il te dit
.
Ajouter un commentaire
Ce document intitulé «  dévérouiller un dossier  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.