[Knoppix] Changer langue de tout le système [Résolu/Fermé]

Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 8 mai 2005 à 23:48 - Dernière réponse : bob031 8215 Messages postés samedi 7 août 2004Date d'inscription 1 septembre 2014 Dernière intervention
- 1 nov. 2008 à 20:18
Salut à tous !

J'ai installé une Knoppix 3.8.1 sur mon disque dur.

Le problème, c'est qu'elle est entièrement en allemand !

J'ai donc changé la disposition du clavier et la langue dans le centre de config KDE.
Seulement, ça ne règle que très partiellement le problème :
- Seuls les élément KDE (barre des tâches, bureau, centre de config, icônes...) sont en français.
- Toutes les autres applications sont en allemand :
- The Gimp, Gaim, Firefox, Thunderbird, toutes les consoles, les messages d'erreurs, etc... sont en allemand.

=>> J'aimerais donc savoir comment faire pour que tout les système soit, par ordre de priorité :
- en français,

- sinon, en anglais.
(mais pas en allemand).

C'est-à-dire: les consoles et toutes les applications (dont celles citées ci-dessus).

Je pense qu'il faut changer quelque chose dans les locales, et/ou reconfigurer le système de packages pour qu'il télécharge les packages en français (ou anglais), mais (malgré toutes mes recherches, je ne sais pas comment m'y prendre).

Merci beaucoup d'avance ! :)

A+ :-)
Afficher la suite 

11 réponses

bob031 8215 Messages postés samedi 7 août 2004Date d'inscription 1 septembre 2014 Dernière intervention - 1 nov. 2008 à 19:51
+1
Utile
2
salut,

je déterre un très vieux post car j'ai un problème de locale aussi sur la gentoo ::
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


j'ai réglé le problème en rajoutant dans le fichier /etc/profile :
export LC_ALL="fr_FR"


puis une petite mise-à-jour de l'environnement :
env-update && source /etc/profile


voilà.
Cette réponse vous a-t-elle aidé ?  
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionModérateurStatut 7 novembre 2010 Dernière intervention - 1 nov. 2008 à 19:54
je déterre un très vieux post
Ben c'est de circonstance ;-DD

Merci ;-)
bob031 8215 Messages postés samedi 7 août 2004Date d'inscription 1 septembre 2014 Dernière intervention > jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionModérateurStatut 7 novembre 2010 Dernière intervention - 1 nov. 2008 à 20:18
no problémo ! :-)
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionContributeurStatut 7 novembre 2010 Dernière intervention - 9 mai 2005 à 08:25
0
Utile
1
Salut Thom@s,

Essaie un petit :
dpkg-reconfigure locales
éventuellement précédé de "sudo".
;-))
Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 9 mai 2005 à 13:04
Salut Jipicy !

Merci pour ta réponse :-)

J'ai fait un "dpkg-reconfigure locales".
J'ai bien sélectionné les "fr*" et "en_US", en choisissant "fr" comme langue par défaut.

• Effectivement, certaines applications sont passées... en anglais :
- The Gimp, la console...

• Par contre, beaucoup d'autres sont restées en allemand, malgré tout :
- Thunderbird, OpenOffice...

Pourtant, toutes ces applications (The Gimp, Thunderbird, OpenOffice, les terminaux) existent en français... mais elles restent en français ou en anglais.

• En revanche, aucune (parmi celles que j'utilise) n'est passée en français.

J'ai fait un update, puis un upgrade des packages: sans effet.

J'imagine que les applications concernées ne sont pas installées en version française.

=>> Peut-être faudrait-il faire télécharger les packages des versions françaises.
Mais comment le faire automatiquement (pour tous les packages disponibles en fr) ?

Merci beaucoup d'avance ! :)

A+ :-)
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionContributeurStatut 7 novembre 2010 Dernière intervention - 9 mai 2005 à 13:23
0
Utile
2
Re-

J'allais te dire de regarder du côté de "kde-i18n", et j'ai fait un tour sur le site de Debian et j'ai trouvé cà :
http://www.debian.org/doc/manuals/fr/debian-fr-howto/ch-autres.html#s6.2
et ça : http://www.debian.org/doc/manuals/fr/debian-fr-howto/ch3.html
C'est pour Debian certes, mais comme la Knoppix est une distribution "based on"... sait-on jamais ;-))
Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 9 mai 2005 à 13:38
Merci beaucoup ! :)

Je vais regarder ça et je te tiens au courant :-)

A+
Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 9 mai 2005 à 19:00
Re,

Voilà ce que me donne un "dpkg-reconfigure locales" (en choisissant les "fr*", les "pl*" et "en_US" (avec "fr_FR@euro" comme langue par défaut):
# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "de",
        LC_ALL = (unset),
        LANG = "de_DE@euro"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_CTYPE to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_MESSAGES to default locale: No such file or directory
/usr/bin/locale: Cannot set LC_ALL to default locale: No such file or directory
Generating locales...
  fr_FR.ISO-8859-15@euro... done
  fr_FR.ISO-8859-1... done
  fr_FR.UTF-8... done
  pl_PL.ISO-8859-2... done
  en_US.ISO-8859-15... done
  fr_FR.UTF-8@euro... done
  pl_PL.UTF-8... done
Generation complete.


Qu'en pensez-vous ?

Merci ! :)

A+

Thomas
Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 9 mai 2005 à 19:33
0
Utile
2
Re,

Finalement, c'est décidé: j'installe Kaella 2.0 :-)
Au moins, là, il n'y aura plus de problème de locales ;-)

Je vous tiens au courant.

A+ :)
jipicy 43485 Messages postés jeudi 28 août 2003Date d'inscriptionContributeurStatut 7 novembre 2010 Dernière intervention - 9 mai 2005 à 20:06
Je crois que c'est pas plus mal, parce qu'avec tous ces "Warnings" et ces "locale: Cannot set", je pense que tu avais un "sérieux problème", ou au pire des cas, un "problème sérieux";-)))
Thom@s 3434 Messages postés mardi 4 mars 2003Date d'inscriptionContributeurStatut 27 août 2010 Dernière intervention - 10 mai 2005 à 07:35
Yep :)

Ca y est, la Kaella est installée.

A+ et merci pour ton aide :)