Signaler

[Knoppix] Error while loading libXmuu.so.1 [Résolu/Fermé]

Posez votre question Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - Dernière réponse le 12 déc. 2006 à 10:23 par toto
Salut !

J'ai installé une Knoppix 3.8.1 que mom disque dur, avec comme racine hdb1 (voir la liste de mes partition dans la config, ci-dessous).

Elle marchait très bien à partir du CD, mais maintenant que je veux la démarrer à partir du disque dur, j'obtiens l'erreur suivante, et Knoppix reste en ligne de commande puis me donne la main :
Starting K Display Manager: kdm/usr/bin/kdm: error while loading shared libraries libX11.so.6: cannot open shared object file: No such file or directory
already running.


Quand je tape ensuite (en ligne de commande seule, en root) startx, j'obtiens cette erreur (à peu près) :
Error while loading shared libraries libXmuu.so.1: cannot open shared object file: No such file or directory.


Je précise que :

1°) Le fichier /usr/X11R6/lib/libX11.so.6 existe, tandis que /usr/X11R6/lib/libXmuu.so.1 n'existe pas.

2°) J'ai installé Knoppix avec la méthode "Beginner", et en éditant le fichier de config de l'installation pour la séparation des partitions (/home, /usr/, /var et /tmp).

3°) Le chargeur LILO n'avait pas été installé par l'installeur Knoppix.
J'ai donc configuré et installé manuellement GRUB, avec une config standard (multi-boot Knoppix/WindowsXP), sans rien ajouter de particulier.
GRUB est dans le MBR du premier disque (celui contenant WindowsXP), hda.

3°) Ca fait ça depuis l'installation: je n'ai jamais encore pu utiliser mon Knoppix sur disque dur.

=>> J'aimerais donc savoir comment faire pour que mon Knoppix démarre correctement ET en mode graphique, avec KDE.
Si vous avez ne serait-ce qu'une idée, un piste (ou la solution ;-) je suis preneur :-)

Merci beaucoup d'avance ! :)

A+ :-)
Utile
+0
plus moins
up :)
Utile
+0
plus moins
Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - 21 avril 2005 à 16:26
Salut Jeff !

Merci pour ta réponse :)

J'ai donc fait (en root, dans la ligne de commande seule, que j'obtiens après l'erreur) :
ldconfig
startx

Auparavant, j'avais ajouté au fichier /etc/ld.so.conf la ligne :
/usr/X11R6/lib
(le répertoire où se trouvent les fameuses librairies manquantes, libXmuu.so.1 et libX11.so.1)

Et là, ça marche: kde s'ouvre... enfin jusqu'au prochain reboot.

En effet, quand je redémarre, j'obtiens à nouveau la même erreur, et je dois refaire exactement la même procédure (ldconfig; startx).

=>> J'aimerais donc savoir comment faire pour "automatiser" la procédure, pour que Linux se "souvienne" de ça.

(Désolé pour le retard: j'étais en train de chercher -en vain- des solutions sur Google)

Merci beaucoup d'avance ! :-)

A+ :)
Utile
+0
plus moins
Tu as essayé "ldconfig -v" ?
Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - 21 avril 2005 à 20:36
Oui, mais ça ne marche pas non plus (ça me donne juste des infos supplémentaires sur ce qui se passe (le nom des librairies)).
Su veux que je te copie-colle le résultat de "ldconfig -v" ?
:-)

A+ et merci :)
Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - 21 avril 2005 à 20:58
Voilà le résultat du ldconfig -v (en root) :
http://cjoint.com/?evuZLDnkMC
Utile
+0
plus moins
Salut Thom@s,

Jette un oeil au "man ldconfig", tu y trouveras notamment :
EXAMPLES
       In the bootup file /etc/rc having the line

              /sbin/ldconfig -v

       will set up the correct links for the shared binaries and  rebuild  the
       cache.
;-))
Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - 21 avril 2005 à 20:57
Salut Jipicy !

Merci pour ta réponse :-)

Je vais jeter un oeil au /etc/rc et je te dis :)

A+
Thom@s 3434Messages postés mardi 4 mars 2003Date d'inscription ContributeurStatut 27 août 2010 Dernière intervention - 21 avril 2005 à 21:25
Re,

Le fichier /etc/rc n'existe pas (j'ai une Knoppix 3.8.1).

J'ai essayé de le créer, avec pour contenu /sbin/ldconf -v, mais sans résultat (je l'ai donc supprimé).

Merci d'avance :)
Utile
+0
plus moins
Re,

Ca y est, ça marche ! :)

Voilà donc ce que j'ai fait (en root), pour faire en sorte que ldconfig s'exécute à chaque démarrage :

1°) J'ai ajouté la ligne suivante au fichier /etc/ld.so.conf :
/usr/X11r6/lib

2°) J'ai créé un script shell /etc/init.d/ldconfig, ayant pour contenu :
#!/bin/sh
su -c"/sbin/ldconfig -v"


3°) J'ai donné les droits d'exécution à ce fichier (/etc/init.d/ldconfig).

4°) Dans une console, j'ai fait :
update-rc.d ldconfig start 30 5 .
(30 pour le n° du processus et 5 pour le runlevel)

Ce qui a pour effet de créer un lien symbolique nommé /etc/rc5.d/S30ldconfig pointant vers mon script /etc/init.d/ldconfig

Merci beaucoup pour votre aide, qui a m'a permis de me mettre sur la voie (le fameux LD_LIBRARY_PATH et ldconfig) ! :)

A+ et bonne nuit ! :-)
toto- 12 déc. 2006 à 10:23
salut,

/etc/rc.local est un bon candidat pour le rajout de lancement de programmes lors du démarrage de la machine.

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !