Apache? [Fermé]

coco - 30 mars 2005 à 11:15 - Dernière réponse : asevere 13080 Messages postés lundi 28 janvier 2002Date d'inscriptionModérateurStatut 13 juillet 2017 Dernière intervention
- 18 mai 2005 à 11:07
bonjours;
A quoi sert un serveur apache?
Afficher la suite 

17 réponses

+1
Utile
je pourrais vous dire a quoi sert votre PC ???
le serveur Apache est un seveur WEB le plus connu et le plus utilisé sur internet, il existe 2 versions l'une Linux et l'autre Windows, la plus utilisée étant Linux car 75% des serveurs WEB sont sous Linux
Ghost
Cette réponse vous a-t-elle aidé ?  
0
Utile
Salut,

J'aimerais faire fonctionné ma config apache sous Linux Fedora 2 mais je n"y arrive que partielement. Pouvez-vous m'aider ?
Mon problème est le suivant :
Sur le poste Linux surlequel j'ai fait l'installation, je peut me connecter sur la page d'accueil par un "localhost" dans Mozilla. Cepandant de mon autre poste sur mon réseau local, ça ne fonctionne pas ... Le réseau est opérationnel mais rien ne semble pouvoir acceder à ma machine linux ...

Merci .
0
Utile
Manuline si tu nous dirais comment tu te connecte a cet autre PC ? quelle commande exacte?

si tu est en réseau et que tu a un routeur?

1) il dois avoir un serveur DNS incorporé (comme le LlINKSYS WRT54G)si tu urtilise le nom de domaine
2) il dois fonctionner si tu utilise le numero ip local comme par exemple http://192.168.xx.xx

Ghost
0
Utile
Bonsoir,

Le resau fonctionne car sur l'autre poste sous windows j'ai installé un serveur de pages web qui fonctione depuis les deux postes et quel que soit le navigateur.
Le ping marche sans probleme sur mes adresses locales 192.168.2.XXX
Je possede un routeur wifi, et je me connecte par http://192.168.2. XXX

Voila, encore merci par avance
0
Utile
tu dis que cele ne fonctionne pas mais que tu te connecte par http://192.168.2.xx ?? donc tu peut y accéder??
Ghost
0
Utile
De la machine linux j'accede au serveur apache par http://localhost mais pas par http://192.168.2.XXX
De la machine windows, j'essaye d'acceder par Http://192.168.2.XXX mais ca ne marche pas ...
0
Utile
Par contre tout fonctionne normalement si j'installe le serveur sur la machine windows ...
0
Utile
3
vérifie si XINET est démarrer
j'espere pas me trmper de nom car cela dépend de la version de linux en tout cas pour une connexion via internet xinet doit être lancer

Ghost
Bonne idée mais, xinetd est bien lancé au démarage ...
ghost > manuline - 10 mai 2005 à 19:52
c'est quasiment impossible, si les 2 PC en LAN n'ont pas de firewall et que http://127.0.0.1 fonctione sur le PC du serveur
fais un dernier essais sur ce même PC en utilisant le N° IP de ce même PC
Ghost
manuline > ghost - 17 mai 2005 à 21:08
Coupé dans mon élan depuis quelques jours...

Avec le N° IP de la machine çà ne marche pas ! Juste avec localhost ....
Je ne sais plus quoi essayé ...

Merci encore pour votre aide.
christophe - 10 mai 2005 à 14:08
0
Utile
1
Bonjour,
si tu as un firewall il faut que le port 80 de ta machine serveur soit accessible depuis le reseau local
Pour l'instant, je n'ai pas installé le firewall ... donc pas de problème (imédiat !) de ce côté là !
Merci .
asevere 13080 Messages postés lundi 28 janvier 2002Date d'inscriptionModérateurStatut 13 juillet 2017 Dernière intervention - 17 mai 2005 à 23:03
0
Utile
2
Bonsoir,

Alors, je vais tenter de résumer:

PC1 -- Linux -- 192.168.2.1
PC2 -- Windows -- 192.168.8.2

(au passage, les ip en 192.168.* sont des ip locales, tu n'as aucun risque à les dévoiler ici, ça aiderait même a la compréhension)

Sur PC1 http://localhost/ [OK]
Sur PC1 http://192.168.8.1 [KO]
Sur PC2 http://192.168.8.1 [KO]
Sur PC2 ping 192.168.8.1 [OK]
Sur PC1 ping 192.168.8.2 [OK]

Donc a partir de là, plusieures possibilitées
En admettant que sur PC1, http://127.0.0.1/ fonctionne (C'est le cas?)

Sol 1 -- Peu probable
Apache est configuré pour écouter sur l'interface lo (127.0.0.1/localhost) et uniquement sur celle ci.

Sol 2 -- Tu as un Firewall installer sur PC1, ce qui est fort probable si tu as installé Linux en laissant plus ou moins les choix par défaut.

Ce que tu peux déjà tenter sur la machine linux, en utilisateur root:
iptables -F
iptables -P INPUT ACCEPT
iptables -P OUTPUT ACCEPT
iptables -P FORWARD ACCEPT

S'il te dit qu'il ne connait iptables, passes les même commandes avec ipchains...

Ce n'est que temporaire, ça te permettra de voir si ça fonctionne ou non
Aprés, il faudra sans doute rajouter en dure une regle du type:
iptables -A INPUT -dport 80 -j ACCEPT, ou quelque chose de plus fin selon tes attentes :)

bye
Merci beaucoup ...

Le coup des iptables m'a ENFIN sorti de ce probleme !!!!

Il ne me reste plus qu'à bucher la dessus afin de fixer les choses plus clairement ... en commencant par ce qu'il a dans ma tête, avant la machine !

Encore merci à tous de votre aide !
asevere 13080 Messages postés lundi 28 janvier 2002Date d'inscriptionModérateurStatut 13 juillet 2017 Dernière intervention > manuline - 18 mai 2005 à 11:07
De rien :)

Si tu as un soucis pour configurer iptable en dur, post un nouveau message dans le forum, les solutions ne manquent pas :)

++
mamiemando 28092 Messages postés jeudi 12 mai 2005Date d'inscriptionContributeurStatut 13 décembre 2017 Dernière intervention - 18 mai 2005 à 09:36
0
Utile
Petites questions pour essayer de localiser le problème...

1) As-tu bien pensé à lancer ton serveur apache ?
service httpd start

ou truc dans le genre...

2) Peux tu faire un petit coup de nmap sur ta machine pour vérifier si le port http est bien ouvert ?

3) Vérifie tes fichiers de conf.

4) Passes-tu par un proxy ? C'est peut-être lui qui filtre...

5) Que t'affiche exactement ton navigateur lorsque tu te connectes en 192.168.... ?

6) Est-ce que tu parviens à te connecter sur ton site depuis le pc qui te sert de serveur avec l'ip 192.168... ?