Menu

Formule excel avec condition [Résolu/Fermé]

cdrom1975 - 8 août 2009 à 11:07 - Dernière réponse :  cdrom1975
- 8 août 2009 à 16:58
Bonjour, j'ai un soucis avec excell version 2007 le probleme me semble simple a solutionner mais je n'ai pas les competences necessaires.
Voici ma question:
j'ai créé un tableau Excel avec 4 colonnes.
dans la colonne A, les dates
dans la colone B un poids
dans la colone C, perte de poids
dans la colonne D, prise de poids.

Mon probleme est de trouver la formule avec cette condition:
Si la difference entre jour J et jour J+1 est negative, calculer la difference dans la colonne C (perte de poids)
Si la difference entre le jour J et le jour J+1 est positive, calculer la difference dans la colonne D (prise de poids)

Pouvez vous m'aider a trouver cette formule svp et si possible m'expliquer le detail
Merci par avance
Afficher la suite 

7 réponses

Vaucluse 21311 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 19 février 2018 Dernière intervention - 8 août 2009 à 11:45
0
Utile
Bonjour
on suppose que la colonne A sert à empiler les dates successives?
Dans ce cas, si votre première ligne est en 2 soit A2 1° date et B2 1° poids:
EN C3
=SI(B2>B3;B3-B2;"")
EN D3:
=SI(B2>B3;"";B3-B2)
ça devrait marcher (à tirer sur la hauteur du champ)
Crdlmnt
0
Utile
bonjour vaucluse.
cela ne fonctionne pas meme si vous avez compris l'apparence du tableau.
En effet, la deuxieme ligne est bien le jour J et la colonne B2 correspond bien au poids.
Je veux qu'excel me calcule la perte ou la prise de poids en rentrant simplement
le poids dans la colonne B.

avec la formule si dessus, j'ai le meme resultat dans la colonne C et D si "B JOUR J" est superieur à "B jour J+1
par exemple:
Jour J=71, Jour J+1=70... j'ai -1 dans les colonne C et D

et il n'y a pas de resultat si B "J+1" est supperieur a B "J"

merci quand meme
argixu 4763 Messages postés dimanche 22 juillet 2007Date d'inscriptionContributeurStatut 19 février 2018 Dernière intervention - 8 août 2009 à 12:46
0
Utile
Bonjour cdrom
Coucou Vaucluse :-)

Si ça marche.
En D3 tu as du copier la formule de C3, et la colonne s'est décalée et calcule sur C. Vérifie.
alors qu'en D3 Monsieur Vaucluse a dit de mettre =SI(B2>B3;"";B3-B2) puis tirer vers le bas.

Quand J+1 sera égal à J, il t'affichera 0. Tu fais Outils/Options/onglet affichage : déchoche valeur zéro
pépé35530 2951 Messages postés vendredi 1 mai 2009Date d'inscription 19 mars 2016 Dernière intervention - 8 août 2009 à 12:59
0
Utile
Bonjour,

j'ai à peu près les mêmes formules :

en colonne Prise de poids

=SI(B3-B2>0;+B3-B2;"")

en colonne perte de poids :


=SI(B3-B2<0;+B2-B3;"")
A+

pépé
Vaucluse 21311 Messages postés lundi 23 juillet 2007Date d'inscriptionContributeurStatut 19 février 2018 Dernière intervention - 8 août 2009 à 13:10
0
Utile
Coucou Argi...!Merci pour le "monsieur" Vaucluse, Madame Argixu...!

Cdrom:

Petit complément
Si vous voulez la perte de poids en colonne C en valeur positive, il faut mettre dans la formule:

B2-B3 au lieu de B3-B2.
Pour le reste, Argi(t)xu a raison et ça devrait marcher.
en colonne C, la cellule est vide si B3 est supèrieur à B2
en colonne D, la cellule est vide si B2 est supèrieur à B3

Pour évoiter l'affichage de 0 si B2=B3, vous poiuvez suivre le conseil d'Argi, ou alors si vous avez besoin des 0 dans d'autres cellules,rajouter en tête de formule:
=SI(B2=B3;"";SI(etc<..... et fermer l'ensemble avec une double parenthèse.

Crdlmnt



Cdrom:
Utilisateur anonyme - 8 août 2009 à 15:35
0
Utile
Bonjour à tous,
Quelques affichages fantaisistes peuvent se produire en cas de cellules vides.
Pour les éviter on peut entrer en C3=SI(ET(ESTNUM(B3);B2>B3);B2-B3;"")
et en D3=SI(ET(ESTNUM(B2);B2<=B3);B3-B2;"")
Bon week-end.
0
Utile
re bonjour et merci a tous pour votre aide

j'utilise la formule de pepe qui fonctionne bien.

encore merci