Signaler

Problème entre recherchev & format cellules [Fermé]

Posez votre question Pep56 11Messages postés vendredi 20 mars 2009Date d'inscription 26 avril 2010 Dernière intervention - Dernière réponse le 4 mars 2016 à 10:12 par MoiExcel
Bonjour,

J'ai un problème avec la recherchev d'Excel, sur un tableau de 9000 lignes. Je dois effectuer une recherche pour compléter 2 colonnes (la recherche est basée sur la feuille 2), à partir d'un nombre. Le problème est que le résultat de cette recherche est le message d'erreur : #N/A.
En fait ma formule est bonne, le souci c'est que je suis obligé d'aller sur chaque cellule de la feuille 2, de rentrer dans la cellule et de taper entrée pour que la réponse apparaisse sur la feuille 1...vous comprenez que sur 9000 lignes cela est compliqué. Le format des cellules est "standard", j'ai essayé en passant tout en nombre ou en texte, mais rien n'y fait...

Merci de votre aide...
Utile
+11
plus moins
Bonjour,

si ta colonne de recherche est le résultat d'une formule sélectionne la colonne et fais 'remplacer' = par =
Si c'est des nombres tente avec 'remplacer' 0 par 0, 1 par 1 jusqu'à être sûr que toutes les cellules aient au moins 1 de ces chiffres et aient été traitées.
Ca devrait forcer excel à ré-évaluer ces cellules.
eric
Cette réponse vous a-t-elle aidé ?  
Koroiboss- 12 févr. 2015 à 09:32
Un GRAND merci ! Tu m'as aidé à trouver une solution à un problème sur lequel je galère depuis plus de 12h ! Merci
MoiExcel 7Messages postés mardi 1 mars 2016Date d'inscription 4 mars 2016 Dernière intervention - 4 mars 2016 à 10:12
bonjour,

Tu me sauves la vie 7 ans après, merci :)
Utile
+3
plus moins
bin, si tu vois pas bien à quoi ce aidera... moi, je me demande ce que je fais sur ce post
ciao
Utile
+2
plus moins
merci eric j'ai essayée de remplacer le 0 par 0 et 1 par 1 et ça fonctionne !
Utile
+1
plus moins
et si tu nous écrivais ta formule
et dans quelle colonne de quelle feuille tu veux le résultat
9000 lignes.... ==> VBA
Utile
+1
plus moins
eh bien bonne journée à toi ! le problème n'est pas sur la recherchev, je sais en faire, le problème est que le format des cellules est mauvais et qu'il faut rentrer dans chaque cellule, faire entree pour que ça marche... à bon entendeur...
Utile
+1
plus moins
merci beaucoup Eric, ça a résolu mon problème. C'est étrange tout de même, cela doit être dû à un souci de format à la base nan ?
Utile
+1
plus moins
Quelqu'un a la solution?
Perso c'est un problème de format et j'ai 1000 ligne à faire entrée donc si quelqu'un sait merci de répondre.

laetitia
Utile
+0
plus moins
ma formule c'est "=RECHERCHEV(D2;Structure!$A$2:$N$1113;3;FAUX)" mais je vois pas bien en quoi ça aidera... Cette formule est sur la feuille 1 colonne B.
Utile
+0
plus moins
...SALUT!
--

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !