Posez votre question Signaler

Probleme avec Grub [Résolu]

Thierry7x 44Messages postés dimanche 7 novembre 2004Date d'inscription 5 février 2006 Dernière intervention - Dernière réponse le 11 nov. 2004 à 22:23
Bonjour,

j'ai installé redhat 9 sur mon pc (l'installation s'est passé normalement) .Au démarage Grub se lance pour choisir un Os (j'ai Xp pro sur hda et redhat hdb) mais je ne peux rien choisir j'ai un ecran tout noir ou il a ecrit GRUB et aucune touche ne repond sauf ctrl alt sup
Voila mon fichier grub.conf mais je ne sais pas comment le modifier :
#boot=/dev/hda
default=0
timeout=10
splasimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-6smp)
root(hd1,0)
kernel /vmlinuz-2.4.20-6smp ro root=LABEL=/ hdc=ide-scsi
inittrd/initrd-2.4.20-6smp.img
title Red Hat Linux-up (2.4.20-6)
root (hd1,0)
kernel /vmlinuz-2.4.20-6 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-6.img
title DOS
rotnoverify(hd0,1)
chainloder +1

Ps pour pouvoir ecrire ce message j'ai du lancer windows et ila ecrit son programme de boot dans le mbr et donc je crois que grub a ete supprime

Merci
Thierry
Lire la suite 
Réponse
+0
moins plus
salut,
Avec ça : http://www.brothersofnet.freesurf.fr/sans_popup/booterFC2.htm
tu peux reparer ton grub, normalement.
Ensuite, quand tu pourras booter sur ta red hat, on configurera grub pour qu'il accepte de booter sur windows.
Il s'agit d'une doc pour la fedora, mais cela doit faire pareil avec la red hat, au moins pour ça .

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
J'ai suivi tes instructions et j'ai donc cree une diquette de boot (tout c'est passé normalement au cours de la manip) mais quand j'ai redemarre mon ordi xp pro se lance directement (je suis obligé de laisser la disquette pour avoir acces a linux). Pas la moindre trace de grub et je sais pas trop comment faire pour le mettre au demarrage
Ajouter un commentaire
Réponse
+0
moins plus
Bien,
alors passons à la résinstallation de grub sur le mbr ...

Ici, http://www.brothersofnet.freesurf.fr/sans_popup/linux.htm#10, tu trouves ceci :
Once the GRUB package is installed, open a root shell prompt and run the command /sbin/grub-install , where is the location that the GRUB Stage 1 boot loader should be installed.
The following command installs GRUB to the MBR of the master IDE device on the primary IDE bus: /sbin/grub-install /dev/hda
The next time the system boots, the GRUB graphical boot loader menu will appear before the kernel loads into memory.


donc une fois red hat demarré avec la disquette, tu te logues root, et tu tapes :
/sbin/grub-install /dev/hda # entre install et /dev, il y a un espace !
Ceci installe grub sur le mbr du premier disque.
Si tu as bien fait l'intallation de red hat APRES celle de windows, alors grub proposera red hat et windows.
Sinon, il faudrait rajouter ce qui manque à la main ; ce n'est pas terrible, mais attendons les résultats.


No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
J'ai suivi tes instructions mais il y a encore un problème.
Donc j'ai tapé la ligne de commande /sbingrub-install /dev/hda en étant en su
Réponse du shell :
Installation finished.No error reported.
This is the contents of the device map /boot/grub/device.map.
Check if this correct or not.If any of the lines is incorrect,fix it and re-run the script 'grub-install'.

#this device map was generated by anaconda
(fd0) /dev/fd0
(hd0) /dev/hda
(hd1) /dev/hdb

Le shell me rend la main et je redémarre l'ordi. Grub se charge (a ce moment j'ai cru que c'était bon) puis il se bloque :

GRUB Loading stage1.5
GRUB Loading, please wait...
Error 21

Voila la situation si tu as une idée n'hésites pas
Thierry
Ajouter un commentaire
Réponse
+0
moins plus
Salut,

21 : Selected disk does not exist
Cette erreur est retournée si une chaîne désigne un disque ou un périphérique BIOS qui n'est pas présent ou n'est pas reconnu par le BIOS.

http://www.linux-france.org/article/sys/chargeurs/ix86/grub/grub-manual-fr.html#Depannage

Par contre me demande pas ce qui cloche (apparemment rien), j'en sais "fichtrement" rien !

;-))

Z'@+...che.
JP : Zen, my Nuggets ! ;-)
Ajouter un commentaire
Réponse
+0
moins plus
ok merci je vais regarder la config de mon bios mais c'est bizarre car si un disque dur n'est pas reconnu par le bios je n'aurais jamais pu installer linux (hdb) ou windows(hda).
A moins qu'on puisse installer des choses sur un disque dur sans pour autant qu'il soit reconnu par le bios (ca me semble bizarre mais sait on jamais)
Ajouter un commentaire
Réponse
+0
moins plus
boot avec ta disquette
reste en mode texte
logue toi root
et tapes
vi /boot/grub/grub.conf
selectionne le tout avec la souris
passe sur un autre ecran (alt F2)
logue toi root
tape :
vi grub
appuie sur la touche i (insert doit s'afficher en bas)
clique avec le bouton central de ta souris (cela a du coller le contenu de ta selection)
appuie sur ECHAP et tapes :
:x

copie le ficher sur une disquette et colle le ici

NB : il y a d'autres moyens de copier ce fichier, fais comme tu veux, mais colle le ici.

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
comment je fais pour rester en mode texte car quand je boote avec ma disquette je lance linux et il est en mode graphique
Ajouter un commentaire
Réponse
+0
moins plus
c'est bien si tu es en mode texte, ne te casse pas les pieds !
Ouvres un shell et et tapes
vi /boot/grub/grub.conf
copie et colle ici
(pour passer en mode console, il faut appuiyer sur ctrl alt F1 ; ensuite avec lt F7 tu repasses en mode graphique ; les autres ecrans console sont alt F2 à F6)

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
j'ai copié le fichier (ps si tu vois des petits carré c'est qu'il faut passé à la ligne, normalement je les ai tous supprimés)
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdb2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-6smp)
root (hd1,0)
kernel /vmlinuz-2.4.20-6smp ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-6smp.img
title Red Hat Linux-up (2.4.20-6)
root (hd1,0)
kernel /vmlinuz-2.4.20-6 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-6.img
title DOS
rootnoverify (hd0,1)
chainloader +1
"/boot/grub/grub.conf" 23L, 743C 1,1 Tout
Ajouter un commentaire
Réponse
+0
moins plus
je corrige demain
'en peut plus :-P
bye

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
ok johndoe je te remercie car meme si grub ne marche pas encore tu m'as bien aidé. Sinon j'ai regardé mon bios (suite au message de jipicy) et il n'y a qu'un disque dur en master alors que windows et linux reconnaisse bien les deux Peut etre le problème vient de la
Thierry
Ajouter un commentaire
Réponse
+0
moins plus
Pour te donner une idée, voici mon grub.conf, sachant que j'ai deux hdd et 7 ou 8 os dessus dont qq linux :
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/hda3
#          initrd /initrd-version.img
#boot=/dev/hda
default=7
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
password --md5 $1$41ImoKPF$76d2Iw7Ey.4h/GOAXZgOH0
title Fedora Core 1 (2.4.22-1.2115.nptl) (hda)
        root (hd0,0)
        kernel /vmlinuz-2.4.22-1.2115.nptl ro root=LABEL=/ rhgb
        initrd /initrd-2.4.22-1.2115.nptl.img
                                                                                                                             
title Red Hat Linux (2.4.20-8) (hda)
        root (hd0,6)
        kernel /vmlinuz-2.4.20-8 ro root=LABEL=/1 hdc=ide-scsi
        initrd /initrd-2.4.20-8.img
                                                                                                                             
title W2K (hda)
        hide (hd0,2)
        unhide (hd0,1)
        rootnoverify (hd0,1)
        makeactive
        chainloader +1
                                                                                                                             
title XP
        hide (hd0,1)
        unhide (hd0,2)
        rootnoverify (hd0,2)
        makeactive
        chainloader +1
                                                                                                                             
title W98FR (j'ai honte) (hdb)
        map (hd0) (hd1)
        map (hd1) (hd0)
    	rootnoverify (hd1,0)
        makeactive
        chainloader +1
                                                                                                                             
title LTSP [Fedora Core (2.4.22-1.2166.nptl)] (hdb)
        root (hd1,1)
        kernel /vmlinuz-2.4.22-1.2166.nptl ro root=LABEL=/12 hdc=ide-scsi rhgb
        initrd /initrd-2.4.22-1.2166.nptl.img
                                                                                                                             
title Fedora Core 2 (2.6.5-1.358) (hdb)
        root (hd1,4)
        kernel /vmlinuz-2.6.5-1.358 ro root=LABEL=/123 rhgb quiet
        initrd /initrd-2.6.5-1.358.img
                                                                                                                             
title Fedora Core (2.6.6-1.435) (hdb)
        root (hd1,4)
        kernel /vmlinuz-2.6.6-1.435 ro root=LABEL=/123 rhgb quiet
        initrd /initrd-2.6.6-1.435.img


Bref, je ne vois pas où est ton probleme, quant à la config ! :-/

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
si je comprends bien il ya pas de probleme avec mon fichier de config. Il ya une petite difference entre nos deux fichiers :
outre le fait que tu as plus d'os, ta variable défault est a 7 alors que la mienne est a 0.Mais je ne sais pas a quoi elle sert!
A part ca est ce que tu penses que ca peut venir du fait que mon bios ne reconnait pas le deuxieme disque dur. (xp et red hat le reconnaisse) Je te mets ce qu'il a sur mon bios
SATA primary Drive OFF
SATA seconday Drive OFF
Primary Master Drive Hard Drive (-->c'est le dique ou il a xp)
Primary Slave Drive OFF
IDE Drive UDMA ON
Ajouter un commentaire
Réponse
+0
moins plus
Il est certain que
cela vient du bios.
Chaque bios est particulier, mais j'essaierais ça : Primary Slave Drive ON

No money, no honey, One Boss !
Ajouter un commentaire
Réponse
+0
moins plus
j'ai essayé de l'activer mais il marque unknown device bref il ne le reconnait pas.
Ajouter un commentaire
Réponse
+0
moins plus
J'ai une bonne nouvelle à t'annoncer, et oui grub marche. Le problème venait bien du bios car un disque dur n'était pas reconnu. J'ai donc ouvert mon micro et j'ai mis les jumpers du deuxième micro sur cable select (avant il était sur une autre position) et j'ai refait toute la procédure que tu as m'apprise à savoir booter sur la disquette et installr grub.J'ai rédemarré mon pc et grub est apparu j'ai donc bien xp mais j'ai deux linux (je sais pas trop pourquoi mais c'est pas grave).
Voila l'aventure avec grub est finie il ne reste plus qu'a configurer le son et internet et j'aurais plus qu'à laisser tomber xp
Sinon merci pour tout johndoe ca vraiment été sympa de m'aider.
linux n'est pas facile à configurer mais avec des gens comme toi tout devient plus simple.
Ajouter un commentaire
Réponse
+0
moins plus
j'aide de plus en plus rarement, car les gens ne suivent pas les conseils et ont souvent une conduite peu aimable.
Mais je vois que l'inverse peut encore rester vrai ;)
enjoy

No money, no honey, One Boss !
jipicy 42923Messages postés jeudi 28 août 2003Date d'inscription ContributeurStatut 7 novembre 2010 Dernière intervention - 9 nov. 2004 à 22:57
Tout vient à point à qui sait attendre ;-))

Z'@+...che.
JP : Zen, my Nuggets ! ;-)
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
ca s'est bien vrai et merci a toi aussi jipicy.
jipicy 42923Messages postés jeudi 28 août 2003Date d'inscription ContributeurStatut 7 novembre 2010 Dernière intervention - 9 nov. 2004 à 23:08
De rien, j'étais juste là pour raviver la "foi" de l'ami johndoe ;-))

Z'@+...che.
JP : Zen, my Nuggets ! ;-)
Répondre
Ajouter un commentaire
Réponse
+0
moins plus
hello,

J'ai suivis avec passion le dénouement...lol

Faut dire que j'avais le même problème avec grub. J'ai installé XP après Red-hat et j'avais oublié que sur ce disque j'avais du Linux....et oui, lorsque l'on a des systèmes avec tirroir rack et qu'on oublie de noter toute les infos...la cata, j'ai bien réussi à récupérer avec la disquette en bricollant un peu, mais je n'avais pas la connaissance pour aller trouver ce fichier grub.conf et taper aussi la ligner de commande :

/sbin/grub-install /dev/hda

ça marche, quelle bonheur ;-) merci, vive le web :-)

En tout cas j'ai gardé tous les textes de ces forums, j'ai appris plein de truc.

Heeuuu, j'ai une question bête, j'ai une version de Linux Red-Hat (shrike), c'est veux dire quoi ce shrike????
Ajouter un commentaire
Ce document intitulé «  Probleme avec Grub  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.