Fonction si dans excel [Fermé]

gueridon - 22 sept. 2004 à 13:20 - Dernière réponse :  Daav
- 30 janv. 2013 à 16:13
Bonjour à tous,

je cherche à faire une fonction si avec la condition suivante : si ma cellule contient matin alors...
Comment retrouver dans la fonction le code *matin* que l'on utilise dans les filtres.

Merci d'avance
Gueridon
Afficher la suite 

15 réponses

+57
Utile
Les réponses ci-dessus fonctionnent lorsque le texte "matin" est inscrit exactement dans la cellule A2.
S'il s'agit de tester si la cellule contient "matin" (d'où le souhait d'utiliser des * avant et après comme dans les filtres), alors je te propose d'utiliser la fonction CHERCHE qui donne l'emplacement du début du texte dans une chaine, et qui si elle ne trouve pas ce texte renvoie une erreur.
La formule suivante donne le résultat attendu :

=SI(ESTERR(CHERCHE("matin";A2));"ne me convient pas";"OK")

Bonne chance.
Cette réponse vous a-t-elle aidé ?  
+11
Utile
5
Bonjour
la fonction SI permet donner deux résultats différents selon qu'une condition est réalisée ou au contraire qu'elle n'est pas réalisée.
Donne moi l'exemple que tu veux traiter, je te donnerai la façon de rédiger la fonction
Cordialement
Charles
bonjour, j'ai un problème de formule.
J'ai des chiffres d'inscrits dans la colonne A et je voudrais une formule pour savoir si le chiffre que je tape dans la case I8 appartient a un des chiffres de la colonne A

je voulais faire un truc du style : si I8 appartient a A:A alors oui sinon non mais c'est le appartient a A:A qui me pose problème car je ne sais pas comment écrire cette formule.

merci de votre aide
littleange > littleange - 12 avril 2008 à 19:51
personne ??
charles > littleange - 12 avril 2008 à 21:08
Bonjour
Il suffit d'écrire la formule :
=EQUIV(I8;A:A;0)
- si la valeur de la cellule I8 existe dans la colonne A, la formule va retourner le numéro de la première ligne où elle est située ;
- si la valeur n'existe pas, elle retournera la valeur d'erreur N/A# ;
Comme il est gênant d'avoir des valeurs d'erreurs dans une feuille, je te conseille de compléter la formule comme suit :
=1*NON(ESTNA(EQUIV(I8;A:A;0)))
le résultat sera soit 0 si la valeur n'existe pas dans toute la colonne, soit 1 si elle existe
littleange > charles - 13 avril 2008 à 10:56
super merci beaucoup charles
heureusement qu'il y a des sauveurs pour aider les vrai noob en formule excel. Merci Charles
g 1270 Messages postés vendredi 23 avril 2004Date d'inscription 15 mai 2017 Dernière intervention - 22 sept. 2004 à 16:07
+5
Utile
Bonjour,
Et pour éviter que lorsque A2 n'est pas renseigné la réponse soit "ne me convient pas"
=SI(A2="";"";SI(A2="matin";"ok";"ne me convient pas"))
Bonne continuation.

http://perso.wanadoo.fr/gerard.g
+4
Utile
Cela donnerait quelque chose comme cela
=si(a2=*matin*;"ok";"ne convient pas")
Sauf que dans la fonction si, il n'a pas l'air de comprendre le code *
:-)
+4
Utile
<souligne>bonjour,

je souhaiterai avoir une définition exact de la fonction si

merci

sarah
+1
Utile
que ve tu dire par fonction dans le code matin
0
Utile
si tu as mis *matin* c normale il faut mettre "matin"
0
Utile
salut je dois tracer une courbe( rendement en fonction du temps) avec excel mais je nai aucune idee comment ca marche es ce que quelqun pourrait m´aider?? merci
0
Utile
Genre les gens qui postent sans prendre le temps de voir de quoi il s'agit..
cly62 3 Messages postés lundi 8 mars 2010Date d'inscription 8 mars 2010 Dernière intervention - 8 mars 2010 à 17:05
-1
Utile
Bonjour
J'ai besoin de gérer une petite comptabilité pour une petite association.
Mes besoins, (Depenses, Recettes, Bilan).
J'ai créer une page Dep-Rec, une Page Bilan, et une page Codif (Base de donnés) avec les codes comptable don j'ai besoin.
Je suis nul dans la programation de fonction, mais par déduction (avec l'aide d'un livre), voici ce que j'ai établie, mais qui ne marche pas!!!!
=(codif!$D$6:$D$19;SI("Dep-Rec!$E$6:$E$19;dans(codif!$C$6:$C$19<">"";))
Quelq'un peut t'il maider à résoudre mon probleme.
D'avnce merci pour vos précieux conseils.