Posez votre question Signaler

Fonction si dans excel

gueridon - Dernière réponse le 30 janv. 2013 à 16:13
Bonjour à tous,

je cherche à faire une fonction si avec la condition suivante : si ma cellule contient matin alors...
Comment retrouver dans la fonction le code *matin* que l'on utilise dans les filtres.

Merci d'avance
Gueridon
Lire la suite 
Réponse
+56
moins plus
Les réponses ci-dessus fonctionnent lorsque le texte "matin" est inscrit exactement dans la cellule A2.
S'il s'agit de tester si la cellule contient "matin" (d'où le souhait d'utiliser des * avant et après comme dans les filtres), alors je te propose d'utiliser la fonction CHERCHE qui donne l'emplacement du début du texte dans une chaine, et qui si elle ne trouve pas ce texte renvoie une erreur.
La formule suivante donne le résultat attendu :

=SI(ESTERR(CHERCHE("matin";A2));"ne me convient pas";"OK")

Bonne chance.
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+11
moins plus
Bonjour
la fonction SI permet donner deux résultats différents selon qu'une condition est réalisée ou au contraire qu'elle n'est pas réalisée.
Donne moi l'exemple que tu veux traiter, je te donnerai la façon de rédiger la fonction
Cordialement
Charles
littleange- 12 avril 2008 à 18:55
bonjour, j'ai un problème de formule.
J'ai des chiffres d'inscrits dans la colonne A et je voudrais une formule pour savoir si le chiffre que je tape dans la case I8 appartient a un des chiffres de la colonne A

je voulais faire un truc du style : si I8 appartient a A:A alors oui sinon non mais c'est le appartient a A:A qui me pose problème car je ne sais pas comment écrire cette formule.

merci de votre aide
Répondre
littleange- 12 avril 2008 à 19:51
personne ??
Répondre
charles littleange - 12 avril 2008 à 21:08
Bonjour
Il suffit d'écrire la formule :
=EQUIV(I8;A:A;0)
- si la valeur de la cellule I8 existe dans la colonne A, la formule va retourner le numéro de la première ligne où elle est située ;
- si la valeur n'existe pas, elle retournera la valeur d'erreur N/A# ;
Comme il est gênant d'avoir des valeurs d'erreurs dans une feuille, je te conseille de compléter la formule comme suit :
=1*NON(ESTNA(EQUIV(I8;A:A;0)))
le résultat sera soit 0 si la valeur n'existe pas dans toute la colonne, soit 1 si elle existe
Répondre
littleange- 13 avril 2008 à 10:56
super merci beaucoup charles
Répondre
Fab- 27 avril 2012 à 12:07
heureusement qu'il y a des sauveurs pour aider les vrai noob en formule excel. Merci Charles
Répondre
Ajouter un commentaire
Annonces
 
moins plus
Réponse
+5
moins plus
Bonjour,
Et pour éviter que lorsque A2 n'est pas renseigné la réponse soit "ne me convient pas"
=SI(A2="";"";SI(A2="matin";"ok";"ne me convient pas"))
Bonne continuation.

http://perso.wanadoo.fr/gerard.g
Ajouter un commentaire
Réponse
+4
moins plus
<souligne>bonjour,

je souhaiterai avoir une définition exact de la fonction si

merci

sarah
Ajouter un commentaire
Réponse
+3
moins plus
Cela donnerait quelque chose comme cela
=si(a2=*matin*;"ok";"ne convient pas")
Sauf que dans la fonction si, il n'a pas l'air de comprendre le code *
:-)
Ajouter un commentaire
Réponse
+1
moins plus
que ve tu dire par fonction dans le code matin
Ajouter un commentaire
Réponse
+0
moins plus
si tu as mis *matin* c normale il faut mettre "matin"
Ajouter un commentaire
Réponse
+0
moins plus
salut je dois tracer une courbe( rendement en fonction du temps) avec excel mais je nai aucune idee comment ca marche es ce que quelqun pourrait m´aider?? merci
Ajouter un commentaire
Réponse
+0
moins plus
Genre les gens qui postent sans prendre le temps de voir de quoi il s'agit..
Ajouter un commentaire
Réponse
-1
moins plus
Bonjour
J'ai besoin de gérer une petite comptabilité pour une petite association.
Mes besoins, (Depenses, Recettes, Bilan).
J'ai créer une page Dep-Rec, une Page Bilan, et une page Codif (Base de donnés) avec les codes comptable don j'ai besoin.
Je suis nul dans la programation de fonction, mais par déduction (avec l'aide d'un livre), voici ce que j'ai établie, mais qui ne marche pas!!!!
=(codif!$D$6:$D$19;SI("Dep-Rec!$E$6:$E$19;dans(codif!$C$6:$C$19<">"";))
Quelq'un peut t'il maider à résoudre mon probleme.
D'avnce merci pour vos précieux conseils.
Ajouter un commentaire
Ce document intitulé «  fonction si dans excel  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.

Vous n'êtes pas encore membre ?

inscrivez-vous, c'est gratuit et ça prend moins d'une minute !

Les membres obtiennent plus de réponses que les utilisateurs anonymes.

Le fait d'être membre vous permet d'avoir un suivi détaillé de vos demandes.

Le fait d'être membre vous permet d'avoir des options supplémentaires.