Posez votre question »

Fonction RECHERCHEV sur Excel

Juillet 2015


Marche à suivre RECHERCHEV (Excel 2003 & Excel 2007)



Les références


Vous devez sélectionner les références dans votre tableau. Dans cet exemple votre référence est $A$2:$D$10. Une fois votre sélection faite vous cliquez sur Insertion - Nom - Définir (Pour l'exemple ici j'ai donné le nom CHAMPS).


Excel 2007: La définition du nom se fait via le menu Formules.

Emplacement où les données trouvées vont apparaitre

  • Dans cet exemple:
    • H1=Terme à rechercher
    • H4=Description trouvée (colonne2 de notre tableau)
    • H6=Quantité trouvée (colonne 3 de notre tableau)
    • H8=Prix trouvé (colonne 4 de notre tableau)

Les formules


La syntaxe de base de la fonction RECHERCHEV est:
=RECHERCHEV(valeur_recherchée;table_matrice;no_index_col;valeur_proche)
  • H4
    • =RECHERCHEV($H$1;CHAMPS;2;FAUX)
    • En clair, on part du contenu de la cellule H1, on cherche dans la première colonne du tableau CHAMPS la ligne commençant par ce contenu, et on extrait la valeur placée dans la deuxième colonne ; FAUX indique que l'on recherche une correspondance exacte.
    • Pour éviter d'avoir un message #N/A si rien n'est trouvé on utilise la formule suivante et "Inconnu" apparaîtra dans la cellule de résultat.
    • =SI(ESTNA(RECHERCHEV($H$1;CHAMPS;2;FAUX));"Inconnu";RECHERCHEV($H$1;CHAMPS;2;FAUX))
    • Avec Excel 2007 une formule plus courte existe: =SIERREUR(RECHERCHEV($H$1;CHAMPS;2;FAUX);"Inconnu")
  • H6
    • =RECHERCHEV($H$1;CHAMPS;3;FAUX)
    • En clair, on part du contenu de la cellule H1, on cherche dans la première colonne du tableau CHAMPS la ligne commençant par ce contenu, et on extrait la valeur placée dans la troisième colonne ; FAUX indique que l'on recherche une correspondance exacte.
    • Pour éviter d'avoir un message #N/A si rien n'est trouvé on utilise la formule suivante et "Inconnu" apparaîtra dans la cellule de résultat.
    • =SI(ESTNA(RECHERCHEV($H$1;CHAMPS;3;FAUX));"Inconnu";RECHERCHEV($H$1;CHAMPS;3;FAUX))
    • Avec Excel 2007 une formule plus courte existe: =SIERREUR(RECHERCHEV($H$1;CHAMPS;3;FAUX);"Inconnu")
  • H8
    • =RECHERCHEV($H$1;CHAMPS;4;FAUX)
    • En clair, on part du contenu de la cellule H1, on cherche dans la première colonne du tableau CHAMPS la ligne commençant par ce contenu, et on extrait la valeur placée dans la quatrième colonne ; FAUX indique que l'on recherche une correspondance exacte.
    • Pour éviter d'avoir un message #N/A si rien n'est trouvé on utilise la formule suivante et "Inconnu" apparaîtra dans la cellule de résultat.
    • =SI(ESTNA(RECHERCHEV($H$1;CHAMPS;4;FAUX));"Inconnu";RECHERCHEV($H$1;CHAMPS;4;FAUX))
    • Avec Excel 2007 une formule plus courte existe: =SIERREUR(RECHERCHEV($H$1;CHAMPS;4;FAUX);"Inconnu")

Note: Dans la formule on met le paramètre à FAUX si on veut rechercher la valeur exacte (#N/A si non trouvé), on le met à VRAI si on veut la valeur inférieure ou égale la plus proche, et dans ce cas la liste de valeur doit être triée.
Si ce paramètre est omis sa valeur par défaut est VRAI

Pour une lecture illimitée hors ligne, vous avez la possibilité de télécharger gratuitement cet article au format PDF :
Fonction-recherchev-sur-excel.pdf

Réalisé sous la direction de , fondateur de CommentCaMarche.net.

A voir également

Dans la même catégorie

Excel - The VLOOKUP function
Par aakai1056 le 19 mars 2011
Tutorial Função PROCV (VLOOKUP)
Par pintuda le 9 avril 2010
Publié par Ricky38. - Dernière mise à jour par Jeff
Ce document intitulé «  Fonction RECHERCHEV sur Excel  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.