Fonctions de recherche et de référence

Décembre 2016
ADRESSECrée une adresse de cellule sous forme de texte à partir des numéros de ligne et de colonne=ADRESSE(no_lig;no_col;no_abs;A1;feuille_texte)
ZONESRenvoie le nombre de zones dans référence=ZONES(référence)
CHOISIRRenvoie un numéro d’index à partir d’une liste d’arguments=CHOISIR(no_index;valeur1;valeur2;...)
COLONNERenvoie un numéro de colonne en fonction d’une référence donnée=COLONNE(référence)
COLONNESRenvoie le nombre de colonnes d’une matrice ou d’une référence=COLONNES(tableau)
RECHERCHEHRecherche une valeur donnée dans une matrice (ou un tableau) en fonction de la valeur de la première ligne=RECHERCHEH(valeur_cherchée;tableau;no_index_lig;valeur_proche)
LIEN_HYPERTEXTECrée un raccourci pour accéder à un autre emplacement dans le classeur ou ouvrir un document stocké sur un disque local, sur un serveur réseau, sur un intranet ou sur Internet=LIEN_HYPERTEXTE(emplacement_lien;nom_convivial)
INDEX (tableau)Renvoie la valeur d’un élément sélectionné dans un tableau en fonction des nombres de colonne et des lettres de ligne=INDEX(tableau;no_lig;no_col)
INDEX (référence)Renvoie la référence d’une cellule en fonction de l’intersection d’une colonne donnée et d’une ligne donnée=INDEX(réf;no_lig;no_col;zone)
INDIRECTRenvoie la référence d’une chaîne de texte=INDIRECT(réf_texte;a1)
RECHERCHE (vecteur)Renvoie une valeur à partir d’une plage, d’une ligne ou d’une colonne=RECHERCHE(valeur_cherchée;lookup_vector;result_vector)
RECHERCHE (tableau)Renvoie une valeur à partir de la première ligne ou de la première colonne d’une matrice=RECHERCHE(valeur_cherchée;array)
EQUIVRenvoie la position d’un élément dans une matrice correspondant à une valeur spécifique dans un ordre spécifique=EQUIV(valeur_cherchée;tableau_recherche;type)
DECALERRéférencie une plage dont le nombre de lignes et de colonnes est donné dans une cellule ou dans une plage de cellules=DECALER(réf;lignes;colonnes;hauteur;largeur)
LIGNERenvoie un numéro de ligne en fonction d’une référence=LIGNE(référence)
LIGNESRenvoie le nombre de lignes d’une référence ou d’une matrice=ROWS(tableau)
TRANSPOSEChange une plage de cellules verticale en plage horizontale et inversement=TRANSPOSE(tableau)
RECHERCHEVRecherche une valeur dans la colonne la plus à gauche d’un tableau et renvoie une valeur à partir d’un numéro de colonne spécifié=RECHERCHEV(valeur_cherchée;table_matrice;no_index_col;valeur_proche)

A voir également :

Ce document intitulé «  Fonctions de recherche et de référence  » issu de CommentCaMarche (www.commentcamarche.net) est mis à disposition sous les termes de la licence Creative Commons. Vous pouvez copier, modifier des copies de cette page, dans les conditions fixées par la licence, tant que cette note apparaît clairement.